Students unable to save responses in new Hydrosphere unit

Incident Report for Stile Education

Resolved

This incident has been resolved.
Posted May 30, 2025 - 09:20 AEST

Identified

The issue has been identified and a fix is being implemented.
Posted May 29, 2025 - 17:40 AEST

Investigating

Students are unable to save responses for all lessons in The Hydrosphere unit. We are investigating this issue with urgency and will post further updates here.
Posted May 28, 2025 - 17:10 AEST
This incident affected: Student activities (Accessing and completing lessons).