Schools insights page data is reporting inaccurate information

Incident Report for Stile Education

Resolved

We've resolved the issues we've been having with insights data. If you're still noticing something not quite right, please contact our support team on support@stileeducation.com (AU/Rest of World) or sciencesupport@cainc.com (USA).
Posted Mar 02, 2026 - 11:33 AEDT

Investigating

The data on the school insights page is currently not displaying accurate information. Our engineers are aware of the issue an are actively working on a fix.

Data looks to have synced recently, however, is misreporting the number of students and teachers online.
Posted Feb 16, 2026 - 11:37 AEDT
This incident affected: Teacher activities (School Insights Data).