Stile Incident - long load times

Incident Report for Stile Education

Resolved

We've resolved the issues we've been having. If you're still noticing something not quite right, please contact our support team on support@stileeducation.com (AU) or sciencesupport@cainc.com (US)
Posted Apr 22, 2026 - 11:58 AEST

Investigating

Stile is currently impacted by an issue, which is causing extremely long load times. We are investigating and will keep you up to date on this page.
Posted Apr 22, 2026 - 11:17 AEST
This incident affected: Teacher activities (Adding students, Copying from the library, Live updating in Stile, Marking work and leaving feedback, Markbook, Editing lessons, Releasing/Hiding lessons, Accessing Stile X mobile app, School Insights Data), Student activities (Accessing and completing lessons, Viewing videos, Accessing Stile X mobile app), Everyone (Logging in, Uploading files, Class discussion, Loading time, Resetting Passwords, Accessing Stile X resources on the web), Subscription Management (Confirming subscriptions, Adjusting subscriptions, Ordering PL, Ordering Stile X workbooks), and Emails from Stile, Single Sign On.