Missing Stile X Revision Resources

Incident Report for Stile Education

Resolved

We've resolved the issues we've been having with Stile X. If you're still noticing something not quite right, please contact our support team on support@stileeducation.com
Posted Aug 22, 2025 - 15:04 AEST

Identified

Stile is currently impacted by an issue in which some revision resources will disappear from complete units in Stile. Videos, quizzes, and flash cards are still available through the Stile X mobile app.
Posted Aug 15, 2025 - 13:36 AEST
This incident affected: Everyone (Accessing Stile X resources on the web).