Delay in Data Updates on Schools Insights Page

Incident Report for Stile Education

Resolved

This incident has been resolved.
Posted May 26, 2025 - 21:18 AEST

Identified

We’re currently investigating an issue where data on the Schools Insights Page has not been updated since 13/5/25. Our engineering team is aware of the issue and is actively working to identify the cause and restore regular updates.
The list of total students year to date will also be unavailable until a fix is implemented.
Posted May 22, 2025 - 14:57 AEST
This incident affected: Teacher activities (School Insights Data).