School Insights data is out of date.

Incident Report for Stile Education

Resolved

We've resolved the issues we've been having with school insights. If you're still noticing something not quite right, please contact our support team on support@stileeducation.com
Posted Apr 08, 2025 - 10:30 AEST

Identified

We are aware that the administrative insights data on school usage is approximately 8 days old for some customers. We've identified the issue and are working to resolve it as quickly as possible.
Posted Apr 01, 2025 - 22:49 AEDT
This incident affected: Teacher activities (School Insights Data).